From Big Hog, 4 Weeks ago, written in Plain Text.
  1. [root@b ~]# python3 -m pip install --upgrade discordpy
  2. Collecting discordpy
  3.   Downloading discordpy-0.1.1.tar.gz (1.3 kB)
  4. Installing collected packages: discordpy
  5.     Running setup.py install for discordpy ... error
  6.     ERROR: Command errored out with exit status 1:
  7.      command: /usr/bin/python3 -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-ggxfv53e/discordpy/setup.py'"'"'; __file__='"'"'/tmp/pip-install-ggxfv53e/discordpy/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'rn'"'"', '"'"'n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record /tmp/pip-record-xwku67op/install-record.txt --single-version-externally-managed --compile --install-headers /usr/local/include/python3.6m/discordpy                                                                                            
  8.          cwd: /tmp/pip-install-ggxfv53e/discordpy/                                                                                                                                                              
  9.     Complete output (14 lines):                                                                                                                                                                                
  10.     running install                                                                                                                                                                                            
  11.     Traceback (most recent call last):
  12.       File "<string>", line 1, in <module>
  13.       File "/tmp/pip-install-ggxfv53e/discordpy/setup.py", line 47, in <module>
  14.         'discordpy = discordpy.cli:cli',
  15.       File "/usr/lib64/python3.6/distutils/core.py", line 148, in setup
  16.         dist.run_commands()
  17.       File "/usr/lib64/python3.6/distutils/dist.py", line 955, in run_commands
  18.         self.run_command(cmd)
  19.       File "/usr/lib64/python3.6/distutils/dist.py", line 974, in run_command
  20.         cmd_obj.run()
  21.       File "/tmp/pip-install-ggxfv53e/discordpy/setup.py", line 20, in run
  22.         raise Exception("You probably meant to install and run discord-py")
  23.     Exception: You probably meant to install and run discord-py
  24.     ----------------------------------------
  25. ERROR: Command errored out with exit status 1: /usr/bin/python3 -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-ggxfv53e/discordpy/setup.py'"'"'; __file__='"'"'/tmp/pip-install-ggxfv53e/discordpy/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'rn'"'"', '"'"'n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record /tmp/pip-record-xwku67op/install-record.txt --single-version-externally-managed --compile --install-headers /usr/local/include/python3.6m/discordpy Check the logs for full command output.
  26. [root@b ~]# python3 -m pip install --upgrade discord_py
  27. Collecting discord_py
  28.   Using cached discord.py-1.2.5-py3-none-any.whl (655 kB)
  29. Requirement already satisfied, skipping upgrade: websockets<7.0,>=6.0 in /usr/local/lib64/python3.6/site-packages (from discord_py) (6.0)
  30. Requirement already satisfied, skipping upgrade: aiohttp<3.6.0,>=3.3.0 in /usr/local/lib64/python3.6/site-packages (from discord_py) (3.5.4)
  31. Requirement already satisfied, skipping upgrade: multidict<5.0,>=4.0 in /usr/local/lib64/python3.6/site-packages (from aiohttp<3.6.0,>=3.3.0->discord_py) (4.7.4)
  32. Requirement already satisfied, skipping upgrade: yarl<2.0,>=1.0 in /usr/local/lib64/python3.6/site-packages (from aiohttp<3.6.0,>=3.3.0->discord_py) (1.4.2)
  33. Requirement already satisfied, skipping upgrade: typing-extensions>=3.6.5; python_version < "3.7" in /usr/local/lib/python3.6/site-packages (from aiohttp<3.6.0,>=3.3.0->discord_py) (3.7.4.1)
  34. Requirement already satisfied, skipping upgrade: chardet<4.0,>=2.0 in /usr/local/lib/python3.6/site-packages (from aiohttp<3.6.0,>=3.3.0->discord_py) (3.0.4)
  35. Requirement already satisfied, skipping upgrade: attrs>=17.3.0 in /usr/local/lib/python3.6/site-packages (from aiohttp<3.6.0,>=3.3.0->discord_py) (19.3.0)
  36. Requirement already satisfied, skipping upgrade: idna-ssl>=1.0; python_version < "3.7" in /usr/local/lib/python3.6/site-packages (from aiohttp<3.6.0,>=3.3.0->discord_py) (1.1.0)
  37. Requirement already satisfied, skipping upgrade: async-timeout<4.0,>=3.0 in /usr/local/lib/python3.6/site-packages (from aiohttp<3.6.0,>=3.3.0->discord_py) (3.0.1)
  38. Requirement already satisfied, skipping upgrade: idna>=2.0 in /usr/local/lib/python3.6/site-packages (from yarl<2.0,>=1.0->aiohttp<3.6.0,>=3.3.0->discord_py) (2.8)
  39. Installing collected packages: discord-py
  40. Successfully installed discord-py
  41. [root@b ~]# python3 -m pip install --upgrade discord.py
  42. Requirement already up-to-date: discord.py in /usr/local/lib/python3.6/site-packages (1.2.5)
  43. Requirement already satisfied, skipping upgrade: websockets<7.0,>=6.0 in /usr/local/lib64/python3.6/site-packages (from discord.py) (6.0)
  44. Requirement already satisfied, skipping upgrade: aiohttp<3.6.0,>=3.3.0 in /usr/local/lib64/python3.6/site-packages (from discord.py) (3.5.4)
  45. Requirement already satisfied, skipping upgrade: attrs>=17.3.0 in /usr/local/lib/python3.6/site-packages (from aiohttp<3.6.0,>=3.3.0->discord.py) (19.3.0)
  46. Requirement already satisfied, skipping upgrade: idna-ssl>=1.0; python_version < "3.7" in /usr/local/lib/python3.6/site-packages (from aiohttp<3.6.0,>=3.3.0->discord.py) (1.1.0)
  47. Requirement already satisfied, skipping upgrade: async-timeout<4.0,>=3.0 in /usr/local/lib/python3.6/site-packages (from aiohttp<3.6.0,>=3.3.0->discord.py) (3.0.1)
  48. Requirement already satisfied, skipping upgrade: chardet<4.0,>=2.0 in /usr/local/lib/python3.6/site-packages (from aiohttp<3.6.0,>=3.3.0->discord.py) (3.0.4)
  49. Requirement already satisfied, skipping upgrade: yarl<2.0,>=1.0 in /usr/local/lib64/python3.6/site-packages (from aiohttp<3.6.0,>=3.3.0->discord.py) (1.4.2)
  50. Requirement already satisfied, skipping upgrade: multidict<5.0,>=4.0 in /usr/local/lib64/python3.6/site-packages (from aiohttp<3.6.0,>=3.3.0->discord.py) (4.7.4)
  51. Requirement already satisfied, skipping upgrade: typing-extensions>=3.6.5; python_version < "3.7" in /usr/local/lib/python3.6/site-packages (from aiohttp<3.6.0,>=3.3.0->discord.py) (3.7.4.1)
  52. Requirement already satisfied, skipping upgrade: idna>=2.0 in /usr/local/lib/python3.6/site-packages (from idna-ssl>=1.0; python_version < "3.7"->aiohttp<3.6.0,>=3.3.0->discord.py) (2.8)
captcha